Microsoft Office 365 Applications are experiencing intermittent issues.
Incident Report for Allen ISD Information Technology
Resolved
Microsoft is reporting that the O365 authentication issue is resolved.
Posted Sep 28, 2020 - 20:38 CDT
Identified
Users may experience issues when re-authenticating to O365 products like Outlook, OneDrive, Sharepoint and Teams. Microsoft has identified the issue and is working on a fix.

https://status.office365.com/
Posted Sep 28, 2020 - 17:21 CDT
This incident affected: Collaboration and Sharing (Office 365 - Cloud Applications, Office 365 - Exchange Email Services, Office 365 - Sharepoint Services).