External Phone Call Issue
Incident Report for Allen ISD Services
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 13:40 CDT
Identified
This is to inform you that we are currently experiencing an issue with some sites receiving external phone calls. AT&T is aware of the issue and is in the process of restoring services.
Posted Jul 13, 2020 - 15:34 CDT
This incident affected: Telecommunications Systems (Campus Phone Systems).