Canvas Issue
Incident Report for Allen ISD Information Technology
Resolved
Instructure has resolved the issue with Canvas and system are back to working normally.
Posted Mar 25, 2021 - 10:33 CDT
Investigating
Instructure is experiencing issues with Canvas and a fix is being implemented. It is currently unavailable for district staff and students. Instructure status page: https://status.instructure.com.
Posted Mar 25, 2021 - 08:20 CDT
This incident affected: Academic Instructional Services (Canvas).