Cable TV Service Outage
Incident Report for Allen ISD Technology
Resolved
This incident has been resolved.
Posted Jul 01, 2021 - 11:43 CDT
Identified
This is to inform you that Spectrum is experiencing an outage of its cable service, as a result, live TV is out district wide. There is currently no ETA for a repair. We will update status page as we get them.
Posted Jun 23, 2021 - 13:44 CDT