Skyward Student and Finance Outage
Incident Report for Allen ISD Information Technology
Resolved
We have resolved the issue with Skyward Finance and Student, both systems are operational.
Posted Mar 27, 2021 - 17:06 CDT
Investigating
This is to inform you that we are currently experiencing and outage with Skyward Finance and Student. We working quickly to resolve the issue.
Posted Mar 27, 2021 - 14:47 CDT
This incident affected: Skyward Applications (Family Access, Finance - HR Systems, Student Information Systems).