Canvas currently unavailable
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Mar 03, 2021 - 16:33 CST
Identified
Instructure is experiencing issues with Canvas. It is currently unavailable for district staff and students. Instructure status page: https://status.instructure.com.
Posted Mar 03, 2021 - 15:50 CST
This incident affected: Academic Instructional Services (Canvas).