The district live cable TV services are offline. Spectrum is working to restore these services.
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 09:36 CDT
Update
We are continuing to investigate this issue.
Posted Jun 24, 2020 - 09:36 CDT
Update
We are continuing to investigate this issue.
Posted Jun 23, 2020 - 12:50 CDT
Investigating
Spectrum is working to restore these services.
Posted Jun 23, 2020 - 12:50 CDT