Google Drive Partial Outage
Incident Report for Allen ISD Services
Resolved
Google has resolved the Google Drive issue.
Posted Sep 08, 2020 - 12:52 CDT
Investigating
Google has reported that they are investigating an issue with Google Drive. Our staff and students may experience issues trying to access their Google Drive files.
Posted Sep 08, 2020 - 12:43 CDT
This incident affected: Collaboration and Sharing (Google G-Suite - Drive).