Some Canvas users experienced a 503 page error upon login.
Incident Report for Allen ISD Information Technology
Resolved
Instructure has reported that this issue is resolved.
Posted Apr 16, 2020 - 11:32 CDT
Monitoring
Instructure has implement a fix are monitoring the results.

Please visit https://status.instructure.com/ for further details.
Posted Apr 15, 2020 - 16:25 CDT
This incident affected: Academic Instructional Services (Canvas).