Cyber Security Training Outage
Incident Report for Allen ISD Information Technology
Resolved
This incident has been resolved.
Posted May 10, 2021 - 09:11 CDT
Investigating
This is to inform you that our Cyber Security Training vendor ProofPoint is experiencing an outage and are working to correct the issue.
Posted May 04, 2021 - 10:02 CDT
This incident affected: Business Operations Services (Allen ISD Security Training).